Class for Teams - Monitoring Alert for Admin Portal

Incident Report for Class Technologies Inc

Resolved

Upon further investigation, it was identified that a sub-optimized backend process slowed down the Admin Portal on Wednesday, April 9, 2025, from 10:06 AM to 12:30 PM EDT (Eastern Daylight Time) UTC/GMT -4 hours. Class engineers have identified the process and released a fix to optimize it appropriately. All systems remain operational.
Posted Apr 10, 2025 - 10:37 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2025 - 02:41 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 09, 2025 - 12:30 EDT

Update

We are continuing to investigate this issue.
Posted Apr 09, 2025 - 11:16 EDT

Investigating

Wednesday, April 9, 2025, 10:06 AM (Eastern Daylight Time) UTC/GMT -4 hours - Class for Teams Admins may experience intermittent issues loading the Admin Portal settings. We are currently investigating this issue.
Posted Apr 09, 2025 - 10:06 EDT
This incident affected: Class for Teams (Class for Teams US, Class for Teams Canada, Class for Teams South America, Class for Teams Europe, Class for Teams Middle East, Class for Teams Asia Pacific).