AWS Global Service Disruption

Incident Report for Class Technologies Inc

Resolved

AWS has resolved the service disruption. Class services are fully operational.
Posted Oct 20, 2025 - 21:24 EDT

Monitoring

Class services are now operating normally. We are continuing to monitor for any further issues and awaiting the final confirmation from AWS before closing this incident.

More details can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Oct 20, 2025 - 17:54 EDT

Update

Class services continue to recover as more AWS services are being restored.

Our engineering team is working with AWS to mitigate the issue and restore full service as quickly as possible.

More details can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Oct 20, 2025 - 16:37 EDT

Update

AWS continues to apply mitigation steps to resolve the service disruption. Class is seeing signs of recovery, but full restoration is still in progress.

Our engineering team is working with AWS to mitigate the issue and restore full service as quickly as possible.

More details can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Oct 20, 2025 - 14:41 EDT

Identified

AWS has reported additional network connectivity issues that are impacting AWS services for US hosted Class and Collaborate services. South American hosted services may also be affected.

Services operating outside of the US are working as expected.

Our engineering team is working with AWS to mitigate the issue and restore full service as quickly as possible.

More details can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Oct 20, 2025 - 11:38 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:10 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:03 EDT

Monitoring

Monday, October 20, 2025, 5:30 AM EDT (Eastern Daylight Time) UTC/GMT -4 hours - AWS has identified the root cause of the global outage, and AWS services are starting to recover. More details can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.

Class users should now be able to access Class for Zoom and Class for Web sessions. Our Engineering team will continue to monitor Class services.
Posted Oct 20, 2025 - 05:54 EDT
This incident affected: Collaborate (Collaborate (US), Collaborate (Canada), Collaborate (Asia Pacific), Collaborate (Europe)), Class for Zoom (Class US, Class Canada, Class South America, Class Europe, Class Middle East, Class Asia Pacific), and Class for Teams (Class for Teams US).