Class Support Portal Live Chat is Unresponsive

Incident Report for Class Technologies Inc

Resolved

This incident has been resolved. Class Support Portal Live Chat (https://chat.class.com) continues to operate as expected.
Posted Apr 03, 2026 - 06:22 EDT

Investigating

Class Support Portal Live Chat (https://chat.class.com) is currently not responding to prompts. Our team is aware of the issue and is actively investigating to restore full service.

While we work to correct this, we recommend visiting https://support.class.com to access our self-service resources.

To submit a new support case, please use the following methods:

Class Admins: Sign in directly to the Support Portal (https://support.class.com) to open a new case.
Other Class Users: Initiate a chat session at https://chat.class.com, and when prompted, press the "Enter" key twice to display the "Send us a ticket" button.
Posted Apr 02, 2026 - 13:34 EDT
This incident affected: Class Support Portal.