AWS Service Disruption in the ME-SOUTH-1 Region

Incident Report for Class Technologies Inc

Resolved

Class has implemented additional measures to prevent future disruptions. Class services are fully operational.
Posted Mar 03, 2026 - 05:58 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 19:34 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 16:19 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 14:06 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 12:48 EST

Monitoring

A fix has been implemented, and Class services are now operating normally. We are continuing to monitor for any further issues and await the final confirmation from AWS before closing this incident.
Posted Mar 02, 2026 - 05:50 EST

Update

AWS is investigating connectivity and power issues affecting services in the ME-SOUTH-1 region. We will provide more information when it is available. More details on the issue can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Mar 02, 2026 - 04:55 EST

Update

AWS is investigating connectivity and power issues affecting services in the ME-SOUTH-1 region. We will provide more information when it is available. More details on the issue can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Mar 02, 2026 - 03:26 EST

Update

AWS is investigating connectivity and power issues affecting services in the ME-SOUTH-1 region. We will provide more information when it is available. More details on the issue can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Mar 02, 2026 - 02:51 EST

Update

We are continuing to work closely with AWS to resolve the issue. We will provide more information when it is available. More details on the issue can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Mar 02, 2026 - 02:05 EST

Update

We are continuing to work closely with AWS to resolve the issue. We will provide more information when it is available. More details on the issue can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Mar 02, 2026 - 01:46 EST

Identified

AWS has identified a service disruption in the ME-SOUTH-1 region that is affecting users' ability to join classes. Class is actively engaged in troubleshooting and will provide more information when it is available. More details on the issue can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted Mar 02, 2026 - 01:28 EST
This incident affected: Class for Zoom (Class Middle East) and Class for Teams (Class for Teams Middle East).