Class for Teams Recording Issue

Incident Report for Class Technologies Inc

Resolved

The issue has been resolved. The stuck recordings have been reprocessed and should now be available. Please contact Class Support if you continue to experience issues with any recordings stuck in a processing state.
Posted May 21, 2025 - 16:07 EDT

Identified

Class is tracking an issue that is causing a small subset of Class for Teams recordings to be stuck in a processing state.

The issue has been escalated to Microsoft, and we are working with them on a resolution. We will update this article as soon as more information becomes available.
Posted May 21, 2025 - 10:40 EDT
This incident affected: Class for Teams (Class for Teams US, Class for Teams Canada, Class for Teams South America, Class for Teams Europe, Class for Teams Middle East, Class for Teams Asia Pacific).