Class for Teams Join Issues

Incident Report for Class Technologies Inc

Resolved

Microsoft has resolved the service disruption. Class services are fully operational.
Posted Oct 29, 2025 - 20:33 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 19:45 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 19:02 EDT

Update

Our automated tests show that the system has recovered. We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 18:01 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 16:58 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 15:33 EDT

Monitoring

Microsoft has identified the root cause of the outage, and Azure services are starting to recover. More details can be found here: https://azure.status.microsoft/en-us/status.

Class users should now be able to access Class for Teams sessions. Our Engineering team will continue to monitor Class services.
Posted Oct 29, 2025 - 14:30 EDT

Update

We are continuing to work closely with our service provider to resolve the issue. We will provide more information when it is available. More details on the potential issue can be found here: https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 13:55 EDT

Identified

An upstream provider of our Class for Teams product has identified a potential critical issue affecting users' ability to join Class for Teams sessions. Class is actively engaged in troubleshooting, and will provide more information when it is available. More details on the potential issue can be found here: https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 12:55 EDT

Investigating

Class for Teams users are currently unable to join sessions. We have identified an issue with one of our upstream providers and are working closely with them on root cause analysis. We will continue to provide updates as more details become available.
Posted Oct 29, 2025 - 12:26 EDT
This incident affected: Class for Teams (Class for Teams US, Class for Teams Canada, Class for Teams South America, Class for Teams Europe, Class for Teams Middle East, Class for Teams Asia Pacific).