A small subset of Collaborate EU recordings might not contain the whiteboard content
Incident Report for Class Technologies Inc
Postmortem

Wednesday, January 18, 2023, 6:30 PM IST (Irish Standard Time)

The Collaborate team was alerted to an issue with the Whiteboard Recording feature that impacted a subset of Collaborate Recordings during the incident timeframe.  The incident began at approximately 11:15 PM UTC on January 17th as a result of a misconfiguration during a non-impacting fix applied to the Recordings service.  This led to the inability of Whiteboard or Shared Files to be included in Collaborate Recordings, which were instead replaced with a “block color” in the video.

The incident was resolved on January 18th at approximately 11:15 AM UTC.    Affected Recordings cannot be reprocessed to include the Whiteboard or Shared Files data.  Recordings that did not use the Whiteboard or Shared Files feature were unaffected.   All services are fully operational.

The Collaborate team takes today’s service disruption very seriously and has taken immediate steps on corrective actions to ensure this incident does not reoccur.  Testing of the Whiteboard Recording feature was included in the plans that were executed following the application of the fix to the Recordings service.  However, those tests did not properly account for the full set of prerequisites which led to a successful result that was inaccurate.  Additionally, the signature of this incident did not sufficiently get picked up by Collaborate’s robust monitoring and alerting system which led to delays in response time.  Both of these scenarios have been corrected.

Posted Jan 18, 2023 - 16:31 EST

Resolved
Wednesday, January 18, 2023 11:30 am IST (Irish Standard Time)

The Collaborate team is aware that a small subset of Collaborate EU recordings made between January 17 11:15pm and January 18th 11:15am, might not contain the files or whiteboard content shared during the Collaborate session.

All recordings that used application sharing were not affected.

The issue is resolved at this time and all services are available.

We apologize for the inconvenience
Posted Jan 18, 2023 - 06:36 EST
This incident affected: Collaborate (Collaborate (Europe)).